Originally posted by Irishacts:
Hi Domenico.

Well I thought that would fix it because I knew I had selected the Giga Main engine while I was listening in on Mix 2 but nope it still does not work. I will send you the preset file.
I've recorded a little video with my iPhone here showing the odd behaviour.



you are right....found where is the bug..

chorus = 0.000000 ;
transpose = 12.000000 ;
start_note = 0.000000 ;
program = 0.000000 ;
mute = 0.000000 ;
variation = 0.000000 ;
end_note = 54.000000 ;
active = 1.000000 ;
volume = 114.000000 ;
end_volume = 127.000000 ;
patch_file = /home/mediastation/GigaLibrary/Symphony Of Voices/1 - London Choir/CHOIR AHS.gig ;
pan = 0.000000 ;
filter_midi_cc = ;
start_volume = 0.000000 ;
patch_name = CHOIR AHS.gig ;
sound_engine = gigasolo ;
reverb = 127.000000 ;
is_drums = 0.000000 ;

You have selected the GIGASOLO engine, for loading on combi your own sound.
You can see on the preset file the all info on the layer.
program 0.0000 is the program change
variation 0.0000 is the program change variation
for that when you select the combi patch again, will send first this prg+var 0 that is a piano sound.

We have upgrade the new Linuxsampler and for sure the developer forget to enalbe again the flag: If gigasolo ignore the program change/variation.
For that when then you press SAVE again, will sent again the giga sound link and then play again the all layers sounds.
With the al othgers engine that use rge Prg+Var is working fine.
I ask now my developer now to insert again the flag on the new sampler and then I upload the debian update file.
Tested right now the sampler 1.0 and gigasolo work, is only on this new 1.0svn3 that not work. http://www.linuxsampler.org/cvshistory.php?subproject=linuxsampler
we fix it asap.