I work in Swansea, I can call in next week if he's still stuck.

Doesn't 2.4 work in Vista? Or can't you go back from V5?

What exact version do you have Roger? 5.0, 5.1, or 5.1LE?

I think I've found a place to purchase it (V6+) but I don't know whether it is an English version, I'm trying to find out.
_________________________
Help to preserve information about Technics Keyboards.
http://TechnicsKN7000.com
http://KN7000.co.uk
http://TechnicsKeyboards.com
http://wsa1.technicskeyboards.com/
Currently playing: KN7000 KN6500 KN5000 KN3000 KN2000 KN1000 KN901 KN800 P50 WSA1 AX7 EX30