One thing I neglected to point out in my last post is the fact that the WK-8 (megastation) and WK-8SE (special edition) use different operating systems. Trying to hack/install the wrong OS into your instrument can create unexpected results. We cannot provide support in these circumstances.

BTW, I provide support for the US market. If you have issues with a GEM product outside of the US, I suggest you contact the place of purchase for things like new OS versions etc. GEM USA does not have access to products/software that are not sold here in the US.

I will of course be happy to help and answer questions from anyone, anywhere, whenever I can.

Thanks,

Dave
_________________________
Wm. David McMahan
The Modulators