This may sound obvious to some but I need some help.

I have a "Creative PC-MIDI Keyboard" with the traditional Microsoft GS Wavetable/MPU-401. I'm trying to record midi in. It works, however I can only record with the "local" voice, and I can't use any other voices from the various midi programs that I have. I've been told to turn off the "local" voice, however no one has provided a method of doing so. Does anyone here know a general way in which I could turn off the "local" voice and use my other MIDI programs to record with?

I've posted the most helpful info from another board below just to give others ideas of maybe what I'm talking about...

"Turning Off the internal voices of your MIDI keyboard is done by setting it to "Local Off" in the Setup of your KB. Look it up in the manual how this is done.

For changing the voices from within Reaper, open the offending MIDI part in the MIDI editor and in the bottom lane you'll find all the standard MIDI controls. Therein is one control called 'Program Change'. With this control you can draw in a voice change wherever you want/need.
Again, you have to look up the KB manual to see how the MIDI Program Changes are handled/numbered for your controller. If it has more than 128 patches, you may have to insert a 'Bank Change'
command as well in your MIDI part.

Hope this helps a bit and gets you a little farther.