SYNTH ZONE
Visit The Bar For Casual Discussion
Topic Options
#30369 - 05/09/05 04:55 PM ATTENTION AJ XD3 DISPLAY PROBLEM
anthonycarriero Offline
Junior Member

Registered: 02/16/05
Posts: 24
Loc: New Rochelle, New York, USA
AJ or any member:
My XD3 display flickers, darkens and acts erratically with sounds cut off while playing live.
Is the problem at the display connection? Any info on how to clean the connection?
Yhanks in advance to AJ or anyone with more info.

Top
#30370 - 05/11/05 09:19 AM Re: ATTENTION AJ XD3 DISPLAY PROBLEM
Ketron_AJ Offline
Moderator

Registered: 03/21/01
Posts: 3231
Loc: Middletown, DE
You might have to have a technician regulate the power to the CPU board ... it needs to be set at 5.1V (adjuster is on power board that is connected to the mother board - you can use a small screwdriver to turn clockqwise very slowly. You'll need a voltmeter to measure it at the other end - look for cable connected to a +5V label on the motherboard.

Thanks,

AJ
_________________________
[KETRON - USA]
Design Engineer & Product Specialist.
www.KetronAmerica.com

Top
#30371 - 05/11/05 12:53 PM Re: ATTENTION AJ XD3 DISPLAY PROBLEM
anthonycarriero Offline
Junior Member

Registered: 02/16/05
Posts: 24
Loc: New Rochelle, New York, USA
Thanks AJ for your detailed response. I found the voltage to be correct at 5.1.
Just by chance I touched the AC line cord were it goes into the XD3 and the same symptom re-appeared. I then discovered that the XD3 cord could not, perhaps due to poor quality control by the cord maker, sit securely into the XD3.
Fortunately I have the MS40 and, by trying the MS40 cord, saw that it fit securely and eliminated the symptoms. I have since decided to add a strain relief for the main line cord to prevent gravity from disengaging the connection.

Top

Moderator:  Admin, Ketron_AJ, Tonewheeldude 



Help keep Synth Zone Online