Hello Freakman,

I think You forgot to save the Midi-settings first.

When You have changed the Midi-settings, press "Save" while still in the Midi-settings screen. This will save your Midi-settings to a User-Midi Location.
After You did that, exit to Main-screen, and then press "Save" again to save Custom-Startup.

Hope this helps.

Best Regards,