Hello again,

I hope that this is not a bug but a misunderstanding on my part. I need to research this again.

Well, I am using the latest operating system from the keyboard and here is what I tried to do:

1) I recorded few tracks in song mode.

2) I was in "Play view" mode... as you all know in song recording there are two modes:

"recording-mode" and "play-mode". The difference is that in the recording mode you can record a track *Smile*. Furthermore, Screen in the recording mode is dark "highlighted"

3) I wanted to listen to 3 measures in loop:

so I selected: "loop" and then I selected, the start measure and the end measure.

4) I pushed play, and then it started to play the three measures again and again and again.

5) I hit stop, it stopped and then I hit play, it played again and again.

so far so good.

6) I tried to get out of that mode, I could not. I hit stop many times, I tried to change anything on the screen and nothing worked.

The only way to continue working is to power down the keyboard.

Am I missing a thing? Do you have the same problem on your keyboard?