PN80 Piano

Posted by: Anonymous

PN80 Piano - 07/22/05 08:56 AM

Hi All



Not exactly a synthesizer, but it is old a Kawai PN80 electric piano. I have a problem with this beast. Initially it started misbehaving by intermittently failing to power up. Repeated operation of the on/off switch would usually cause it to work correctly. This problem gradually got worse so I decided that the time had come to sort it out.



Initial tests showed that the on/off switch was itself intermittent. I shorted this out and all seemed OK but soon the original problem manifest itself again. Delving into the circuit revealed that the 5 volt regulator was dodgy, the output would jump about, one minute 5V then the next 2V so this I replaced. This cured the erratic 5V rail, now a steady 5.13V.



Now every time I switch on I get a short delay of a few seconds with no sound and then with no prompting I get a cacophony of sound, many keys being played completely at random and nothing will stop it. Hitting another voice key will change the timbre of the sound but still the noise continues.



Iím stumped what could possibly cause this malfunction and why should replacing the regulator cause this. Could it be that prior to making the change an over-voltage has damaged something else? If so what could this be?



Any pointers would be gratefully received.



I am fortunate in that I have the full service manual, but this does not give any description of the circuit only a schematic of the circuit.



Regards



------------------
Brian G3OYU