SYNTH ZONE
Visit The Bar For Casual Discussion
Topic Options
#418760 - 03/26/16 10:27 AM ARP Omni still works, sort of
analogcontrolfreak Offline
Senior Member

Registered: 04/16/03
Posts: 1531
Hey Nigel,

I just plugged in my old ARP Omni, and it still works. Although the volume is increasing staticky. When I move it, the static increases in volume. I figure there is so much dust in there, that is what is causing the problem, or at least part of it. Two keys are dead, due too snapped contact wires under the keys. The string section, still plays alright, but the synth section is a bit sketchy. The 8' still works, but not the 4'. The Chorus Phaser and Waveform Enhancer don't work. The LED light are dead, and I think the buttons are too. Only the 8' Synth Bass works, but not the 16'. the sliders on the left side of the keyboard seem okay, but the ones across the front panel and very sticky. I had this synth repaired, back in the 1990's around the same time I bought it, but I don't think the people who repaired it are still in business. Even though it has it's problems, I hate too get rid of it, since I have had it for so long.

Paul

Top
#418773 - 03/26/16 02:02 PM Re: ARP Omni still works, sort of [Re: analogcontrolfreak]
Nigel Offline
Admin

Registered: 06/01/98
Posts: 5937
Loc: Ventura CA USA
Sounds like it would cost a bit to address all the problems.

Top
#418782 - 03/26/16 09:41 PM Re: ARP Omni still works, sort of [Re: analogcontrolfreak]
analogcontrolfreak Offline
Senior Member

Registered: 04/16/03
Posts: 1531
I'd say so!

Top
#418789 - 03/27/16 09:21 AM Re: ARP Omni still works, sort of [Re: analogcontrolfreak]
analogcontrolfreak Offline
Senior Member

Registered: 04/16/03
Posts: 1531
Well, I tried too clean it, and now it's dead. It only powers on, oh well. Maybe I could find some one local, who wants to buy it cheap.


Edited by analogcontrolfreak (03/27/16 09:22 AM)

Top
#418875 - 03/29/16 10:20 PM Re: ARP Omni still works, sort of [Re: analogcontrolfreak]
Nigel Offline
Admin

Registered: 06/01/98
Posts: 5937
Loc: Ventura CA USA
ouch !!! That's tough it doesn't work at all now. How did you clean it?

Top
#418917 - 03/30/16 01:55 PM Re: ARP Omni still works, sort of [Re: analogcontrolfreak]
analogcontrolfreak Offline
Senior Member

Registered: 04/16/03
Posts: 1531
Yea, I don't know what happened? I took it apart, and used electronics cleaner, too try and clone the circuit boards, and canned air to get the dust out, but when I plugged the cables that had come lose, and switched it on. Only the light in the power switch lit up. Everything else just did not light up, and no sound.

Top
#419184 - 04/05/16 11:45 AM Re: ARP Omni still works, sort of [Re: analogcontrolfreak]
analogcontrolfreak Offline
Senior Member

Registered: 04/16/03
Posts: 1531
Well Nigel, it is listed for sale on eBay.

Top
#419190 - 04/05/16 01:54 PM Re: ARP Omni still works, sort of [Re: analogcontrolfreak]
analogcontrolfreak Offline
Senior Member

Registered: 04/16/03
Posts: 1531
Well, just ended the auction early. Had a buyer who was willing too buy it, and pay for packing and shipping.

Just made $25.00 on a dead keyboard. Which he knows he is getting.

Top

Moderator:  Admin 



Help keep Synth Zone Online